“布林买卖”主图及选股公式(通用)

源码:

Var1:=1;
多空平衡线: EMA(EMA(EMA(HIGH,5),5),4)*Var1, COLORWHITE;
弱势反弹线: 多空平衡线*0.9 ,COLORYELLOW;
Var2:=多空平衡线*0.85;
高位止赢线: 多空平衡线*1.1 , COLORGREEN;
获利了结线: 多空平衡线*1.05 , COLORRED;
强势回挡线: 多空平衡线*0.95 , COLORFF00FF;
A1:=(3*C+L+O+H)/6;{K线中心价格,即当日平均价格,这种形式的速度较慢,但干扰小,或者:A1:=(2*C+H+L)/4;}
A2:=LLV(LOW,34);{34天最低价格,34是费波南茨数列的一个值}
A3:=HHV(HIGH,34);{34天最高价格,34是费波南茨数列的一个值}
A4:=(INDEXC-HHV(INDEXC,8))/HHV(INDEXC,8)<-0.05 and MA(INDEXA,125)/MA(INDEXV,125)/(MA(INDEXA,5)/MA(INDEXV,5))>1.11;
A5:=EMA((A1-A2)/(A3-A2)*A3,7);
A6:=CROSS(A5,MA(A5,7));
A8:=BARSLAST(A4)<13;
风险线:=EMA(A1,45)*1.15;
必卖线:=EMA(A1,55)*1.3;
地线:=EMA(A1,40)*0.85;
铁底线:=EMA(A1,88)*0.7;
成本线:=EMA(A1,55);
价值中枢:=(成本线+地线)/2;
防线:=EMA((A1-LLV(L,31))/(HHV((H+C)/2,21)-LLV(L,31))*100,8);
均线:=SMA(防线,4,1);
快线:=(20*A1+19*REF(A1,1)+18*REF(A1,2)+17*REF(A1,3)+16*REF(A1,4)+15*REF(A1,5)+14*REF(A1,6)+13*REF(A1,7)+12*REF(A1,8)+11*REF(A1,9)+10*REF(A1,10)+9*REF(A1,11)+8*REF(A1,12)+7*REF(A1,13)+6*REF(A1,14)+5*REF(A1,15)+4*REF(A1,16)+3*REF(A1,17)+2*REF(A1,18)+REF(A1,20))/210;
慢线:=MA(快线,10);
A10:=FILTER(快线>ref(快线,2)AND((C/REF(C,3)>1.1)AND(V/REF(V,1)>1.7)),5);
A11:=CROSS(MA(C,30),MA(C,36))AND(C>REF(C,5)*1.05);
DRAWTEXTABS(5,5,”),linethick1,COLOR00EEff;
中长期压力:=MA(A3,3);
上升自然趋势:=MA(LLV(L,13),5);
心:=((H+C)/2+L+(C+L)/2)/3;
中:=EMA((心-EMA(LLV(心,47),2))/(EMA(HHV(心,21),2)-EMA(LLV(心,47),2)),2)*90;
有:=IF(CROSS(-1.8,中),7,-7);
海底:=EMA(A1,89)*0.74;
海平面:=EMA(A1,89)*0.84;
天际:=EMA(A1,134)*0.98;
天空:=EMA(A1,134)*1.08;
突破中长期压力:=FILTER((C>中长期压力*0.97 AND (V/REF(V,1)>1.03) AND C>REF(C,1)),5);
半:=A6 AND 快线<=海平面 AND c>=海底;
全1:=A6 AND C<=海底 AND A8;
全2:=REF(C,1)<海底 AND C>O AND C>海底*0.97;
全3:=REF(C,1)<海底 AND C>O AND C<海底*1.03;
全4:=突破中长期压力 AND C<=海平面*1.03;
DRAWTEXT(FILTER(A6 AND C>海平面 AND A8 AND(C<REF(C,5)*1.05)AND L<天际,5),L-L*0.02,’⊙短买⊙’),coloryellow;
DRAWTEXT(FILTER(全1 OR 全2 OR 全3 OR 全4,5),L*0.97,’全仓买’),Color0000FF;
DRAWTEXT(FILTER((A10 OR A11)AND C>天际,5),H*1.03,’短卖’),COLOR00FF00;
DRAWTEXT(FILTER((快线>REF(快线,3) OR 快线>REF(快线,4))AND 快线<REF(快线,1) AND 快线>天空,8),H*1.05,’全仓卖’),COLOR00FF00;
DRAWTEXT((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),l-0.02,’买’),colorred;
DRAWICON(FILTER(REF(C,1)<海平面 AND C>O AND C>海平面,10),海平面,1);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
e:=CROSS(80,RSI);
DRAWTEXT(e,H+H*0.02,’卖’),COLORff9966;

 

(选股公式:)
A1:=(3*C+L+O+H)/6;
A2:=LLV(LOW,34);
A3:=HHV(HIGH,34);
A4:=(INDEXC-HHV(INDEXC,8))/HHV(INDEXC,8)<-0.05 and MA(INDEXA,125)/MA(INDEXV,125)/(MA(INDEXA,5)/MA(INDEXV,5))>1.11;
A5:=EMA((A1-A2)/(A3-A2)*A3,7);
A6:=CROSS(A5,MA(A5,7));
A8:=BARSLAST(A4)<13;
快线:=(20*A1+19*REF(A1,1)+18*REF(A1,2)+17*REF(A1,3)+16*REF(A1,4)+
15*REF(A1,5)+14*REF(A1,6)+13*REF(A1,7)+12*REF(A1,8)+11*REF(A1,9)+10*REF(A1,10)+
9*REF(A1,11)+8*REF(A1,12)+7*REF(A1,13)+6*REF(A1,14)+5*REF(A1,15)+4*REF(A1,16)+
3*REF(A1,17)+2*REF(A1,18)+REF(A1,20))/210;
海底:=EMA(A1,89)*0.74;
海平面:=EMA(A1,89)*0.84;
中长期压力:=MA(A3,3);
突破中长期压力:=FILTER((C>中长期压力*0.97 AND (V/REF(V,1)>1.03) AND C>REF(C,1)),5);
全1:=A6 AND C<=海底 AND A8;
全2:=REF(C,1)<海底 AND C>O AND C>海底*0.97;
全3:=REF(C,1)<海底 AND C>O AND C<海底*1.03;
全4:=突破中长期压力 AND C<=海平面*1.03;
全仓买:全1 OR 全2 OR 全3 OR 全4;

About 智足者富

http://chenpeng.info

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>