configure: error: no, libmemcached sasl support is not enabled.

CentOS 6.9 安装PHP拓展Memcached2.2.0时遇到的问题。

搜索后得到的答案是libmemcached版本过低,验证后确实如此。

 

Memcached >2.1 requires at least libmemcached 1.x. You seem to have 0.31 still installed.

Remove the current libmemcached packages and install libmemcached10 (plus the -devel).

These packages can be found in (at least) IUS repository.

 

现有系统安装的库版本为0.31,需要升级到1.x版本。yum没找到libmemcached10版本,估计是没安装合适的第三方库。

编译安装一个

wget https://launchpad.net/libmemcached/1.0/1.0.18/+download/libmemcached-1.0.18.tar.gz -O – | tar -xz
cd `ls . | egrep ‘libmemcached-*’ | head -1`
./configure
make && make install

再次执行pecl install memcached-2.2.0安装成功。

About 智足者富

http://chenpeng.info

发表评论

电子邮件地址不会被公开。 必填项已用*标注

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>